Bugs after furioos update 11.12.2019

  • Hello Furioos,

    yesterday you made updates to your service and now several things are broken which worked great before. I don’t know if your update is still in progress and the issues are only temporary, but I’ll share my observations either way, in case it helps.

    I’d love to hear if these are things that you intend to fix or if this is related to some new settings on your side which require me to re-design my applications.

     

    Loading Apps on PC in Firefox does not work any more (windows 10 home, Firefox 71.0 (64bit))

    Test App 1: loading process runs until “Start streaming”, then it gets stuck and just jumps back and forth between “Start streaming” and “The streaming has been disconnected”.

    Test App 2: The loading process gets stuck on “copying your app on the server”. The progress bar does not even start moving.

    Test App 3: A notice appears saying “Session stopped”, then the loading process is also stuck on “Copying your app on the server”.

     

    Fullscreen on Android (6.0.1) and Firefox (68.2.1)

    Window does not go to fullscreen when touching the icon. However the menu disappears and it does not come back with double/finger double tap.

    Fullscreen works on Android with Chrome (78.0.3904.108)

    Fullscreen works on iPad in Safari.

    Touch input messed with “mouse locked”

    After touching the fullscreen icon (in Firefox) the window does not go to fullscreen, but one-finger drag gestures are now broken. This is related to the mouse mode: when going to fullscreen you now set the mouse to “locked”. In locked mode one-finger drag input is broken. I used this to turn the view, now the view just jiggles around as if the input value was always forced back to zero.
    This is also happening in Chrome.
    This is also happening on iPad in Safari

    Default Cursor

    Previously, the windows cursor was always visible on top of the furioos app window and the internal cursor of the app was also visible, just delayed. In order to avoid seeing two cursors I set up my apps to hide the internal cursor and only use the real-time windows cursor (which works great!)
    Now you hide the default windows cursor all the time. I would have to use the internal app cursor again, but due to network lag this is always lagging behind. Can I get the default windows cursor back?

    As another observation, the app internal cursor now suddenly appears after touching a UI button, which was not the case before (because I had deliberately hidden it). Why does it now show up all of a sudden?

     

    Can you give me some feedback on the above, so I can decide if I should pause my paid subscription?

     

    Thanks

    Hi BenHKVR,

    Sorry for the inconvenience, we’ve made an update this morning and another is deploying yet to fix some bugs.

    I tried your apps on Chrome and FF and everything goes right, could you please try again and tell me if it’s good ?

    For the mouseLock touch bug we’ve fixed it this morning.
    I suggest you to activate the cursor on your app because we’ve choose to only display the server cursor for now. We are working on a better integration of the cursor to reduce latency felling.

    Looking forward to your answer to know if everything is OK for you 😉

    Best,

     

    Hello,

    Thank you for the response. Here is my feedback:

    Loading Apps on PC in Firefox does not work any more (windows 10 home, Firefox 71.0 (64bit))

    I still can’t load any of the apps in Firefox. I get all the way to “Start streaming” and then it gets stuck at this point. Every two seconds the message jumkps to “The streaming has been disconnected” and then goes back to “Start streaming”. But no further.

    Fullscreen on Android (6.0.1) and Firefox (68.2.1)

    Fullscreen does not work in Firefox yet.

    Fullscreen does NOT work on iPad in Safari any more (iPad Air, iOS 12.2)

    Fullscreen works in Chrome BUT:

    there is now some scaling issue in fullscreen mode? In fullscreen I can not interact with buttons on the far right of the screen. I have got a button in the top right corner and one in the bottom right corner and I can’t touch them. I see the UI perfectly, but the buttons don’t react. In normal mode I can touch them, in fullscreen I can not touch them.

     

    Touch input messed with “mouse locked”

    This is fixed, thank you!

     

    Default Cursor

    OK, but this is a bit of a problem. My apps are supposed to run on PC AND mobile devices:
    – on PC I need to see a cursor. The app cursor is sluggish and delayed, so the Windows cursor is much better.
    – BUT on mobile I don’t want to see a cursor at all. It’s all touch controlled, no mouse. So now I need a way to identify which device my app is running on so I can control the visibility of the app cursor accordingly.

     

    Thank you for your efforts. Please keep me updated on these points.

    • This reply was modified 3 years, 1 month ago by BenHKVR. Reason: additional info for fullscreen issue

    Hi Ben,

    I tried again to find your problem on Firefox but even if i tried with the same version but with a pro windows (i don’t have something else) i get all app running even on your organisation.
    Maybe you have some information in the console ? can you share me a screen of this ?

    For the fullscreen android, can you please tell me which app of your side is concern ? thus i can test it and see what’s wrong and fix if needed.

    I understand your problem with the cursor and we will implement a better integration of the cursor in the client side (thus we can detect mobile and hide the mouse cursor) during the next week. I hope you understand that we don’t want to work on a little hack because a better integration will come soon.

    Thank’s for your patience 🙂
    Best,

    Hello Maxence,

    can I send you a personal message or E-Mail to go into more detail?

    Yeah sure, here’s my mail : m.brasselet@furioos.com

You must be logged in to reply to this topic.